Forum - Beitrag anzeigen

Archiv Spectra - RE: Perfomance Probleme (Webtop)

Icon Pfeil Startseite Icon Pfeil Kategorie Icon Pfeil Suche

Icon Forum Beitrag vom 05.03.2002 14:27 (1330 Aufrufe)
Name: Hendrik Kramer
Titel: RE: Perfomance Probleme (Webtop)
Inhalt: 1-2 Minuten sind ziemlich lange für das Anlegen eines Objektes. Bei uns sind es via WebTop (Testserver) ca. 30 sec. beim ersten Aufruf, dann ca. 4-5 sec. (P 266/512 MB). Allerdings arbeite ich nicht oder kaum mit dem Webtop. Für Types und Properties habe ich eine eigene Miniseite entwickelt, der ContentFinder und die Objektbearbeitung ist auch selbst geschrieben. Vorteile: Alles läuft jetzt im 30-700 ms Bereich ab.

Empfehlung:

1. Verwende möglichst cfa_browser, cfa_button und cfa_style nicht. Die bremsen die Performance enorm aus. Ohne diese Funktionen und mit ein paar Minioptimierungen sind auch komplexe e-commerce Sites ohne Caching sehr schnell (inkl. Container, Publishing Rules, Logging, Menüaufbau, Site Layout Model, Workflow, User Profiles, ...).

2. Webtop nur für Entwicklung benutzen (oder besser programmgesteuert), sonst die wichtigsten Element (Object.cfm, invoke.cfm und contentFinder durch eigene Versionen ersetzen.






--
Hendrik Kramer <hkramer@vrg.de>
Teamleiter Web Application Development [VRG E-Solution]
VRG - Vereinigte Rechenzentren GmbH
Mittelkamp 110-118 , 26125 Oldenburg
Tel. (0441) 3907-178 | Fax (0441) 3907-6-178
http://www.e-solution.vrg.de/


Bitte melden Sie sich kostenlos an, um eine Antwort auf diesen Beitrag zu erstellen.


Das deutsche ColdFusion-Forum cfml.de ist das Portal für Einsteiger und Experten zum Thema ColdFusion und der ColdFusion Markup Language (CFML).

© 2017 Webdesign & Hosting: CHC ONLINE Kassel | SOLVA Content-Management-System CMS
Urlaub-Angebote.de - Urlaub mit Bestpreis-Garantie buchen